Blender Scenery Not Appearing

  • I'm having a real problem where objects I create in Blender and then put into my custom scene don't appear in the sim unless at very close range. Once they appear they seem to stay visible at all ranges but they just wont show unless you are practically on top of them. This is obviously very frustrating as it ruins the point of making scenery. I spent a lot of time making a building only to have this problem occur so I tried again using just the default cube from Blender (in case I had corrupted a setting along the way in my complex building) with a simple texture attached and had the same problem! I have made scenery successfully before but it was with a slightly older version of both the MSFS SDK and Blender. The SDK has changed a little bit since then. Have no idea how to even go about tackling this. Has anyone got any ideas?

  • Thanks so much for your help. I fixed it! It was indeed due to scale. I had started the model by scaling up the default cube to roughly the building dimensions and gone from there. It means the finished model X, Y and Z scale were all large numbers. I assume this meant that MSFS doesn't think it has to draw it because you are always "far away". So all I had to do was go into the model and renormalise the scale to 1.0 (Select model, hit CTRL + A, select "Scale", check all scale axis have returned to 1.0). Hope that helps anyone else who might encounter this problem!