No avionics after Update 7

  • After update 7 initially everything looked ok. I then loaded the Harvard pack from the store. Thereafter it was not possible to get any avionics and no VFR map. I tried everything now for about two days, but without any result. Does anybody have the same problem or know a solution? Thanks for your help.

  • You might try uninstalling the Harvard. If that fixes the problem, take up the issue with the makers of the Harvard. If not, you've at least eliminated the Harvard as a factor, There don't appear to be any avionics problems reported over on flightsimulator.com but as this appears to be a Microsoft/Asobo problem, that would be the best place to start.

    JohnG

    From Oz, Flight Simmer since FS1 - seriously since FS95

    Contributed to, and managed a site called ProjectAI for a time

  • Thank you John. I tried everything but to no avail. Your hints on utube I followed and I at least got rid of the nuisnance help functions. As last reort I sent the message to the zen helpdesk and hope they can fix it.

  • You've done the right thing, but you may just get a quicker answer from the flightsimulator.com forums - you might even find that it's been resolved already with a bit of judicious searching.

    Good luck.

    JohnG

    From Oz, Flight Simmer since FS1 - seriously since FS95

    Contributed to, and managed a site called ProjectAI for a time

  • Hi John,

    I tried all the given solutions in the flightsimulator forums. Never did it work. I went through all the helpdesk ideas. It did not work. From the paid addons, only a couple worked. The others will probably have to wait till the next update. I checked my whole PC system for the latest updates in Windows and Geforce. All seem to be correct. But the fact still remains that all of the aircraft in the hangar do not have any avionics. You cannot turn them on or off, you cannot call them up via the keyboard. It is all very frustrating. So I am convinced that the last MSFS update must be the cause.

    Thanks a lot.

  • The misery in MSFS after the lust update: Apart from the trouble with the avionics and the vfr map, I cannot play with the following Aircraft Addons: Milviz Corsair, Flying irons P-38 and Spitfire. Th loading in the World Map slows at around 90% and stops at the end. The only way to leave the game is via CTL-ALT-DEL. The addon liveries for the Microsoft T-6 Harvard do not work and probably a lot more which I could not check untill now. I am very curious if anyone has the same problems or mabe a solution. I contacted already Milviz, but they answered that they could not reproduce the failure to load. Thanks a lot for your help.